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Visual Streamline FAQ 

Visual Label Designer Program 
 

Program Overview: 

The Visual Streamline Label Designer application is an enhancement to the visual streamline software package.   It 
allows customers to customize, modify, and print various labels that can be used within the software.  The Label 
Designer Program is an external application.  It consists of several integration points for printing labels from the 
label Designer Program directly, and from within the software.  The Label Designer Program will be accessible from 
our Web Services module, and also from the handheld as the demand for labeling increases.    

 

The current integration points within the software are as follows: 

 

Receiving 

Shipping 

Inventory Levels  

 

The integration points are controlled through a flag in the control file maintenance under the MISC tab.  There are 
also two business rule that must be turned on to allow for the receiving integration.  The business rules are Sales 
Order #41 – Print Shipping Label After Printing Packing Slip – and Purchase Order  # 36 – Print Receiving Labels.   

 

Supported Printers: 

 

Any thermal transfer or dot matrix printer such as:  Toshiba TEC thermal printers (our usual recommendation) will 
work. Provided that it can be installed in windows, is a GDI based printer driver, and uses continuous feed labels.  A 
GDI based printer driver simply means that you can print to the printer from any program (such as MS Word) 
without the need for special coding.  For example, a Zebra ZPL printer driver will not work as it uses a proprietary 
print language, so only software coded to use the ZPL language can print to it (such as the Zebra BarTender 
software).  It is the site’s responsibility to ensure that the printer used supports the size of labels that need to be 
printed.  For example:  If you have a dot matrix printer that only supports labels as small as 3” W X 1” H, you will 
NOT be able to use this printer to print labels that are 3”W X 0.5” H, regardless of whether you could use that 
printer for that size of label for any other label software, including the old magic label print routines.    Our old label 
printing routines wrote the info directly to the printer line by line, keeping track of the number of lines/columns 
printed internally to make everything fit.  The new labeling software uses correct paper sizes to manage this. 
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Setup: 

To access Visual Streamline Label Designer, click on:  Start > All Programs > Visual Streamline Designer.   

See screenshot below: 

  

 
 

The first time a user runs the designer application, they will be prompted to select the Server to connect to, the 
timeout (in seconds) to wait for a connection or query to complete before generating an error message, and the 
company to use for the preview data.  Preview data is a single row of data from the server that is inserted into 
bound objects when you bind it to a column.  This is to assist with formatting by allowing you to see sample data in 
the objects at design time.  Users can go back in and modify these settings by clicking on “File” and going to 
“Settings”. 

 

 
Once this setup is done, you are ready to begin using the program. 
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Functionality: 

 

Creating a New Label: 

 

To create a new label, click on the “File” menu, and then click on “New”.  You will be presented with the New Label 
Dialog window.   

In this dialog window on the “General tab” is where you specify the Type of the label, whether the label should be 
Global or Company Specific.  If you have multiple companies set up, it’s important to define this criteria up front.  If 
you select a specific company’ that label will only be available from the company that has been defined. Next, enter 
the name of the label, a description of the label (optional), and the units of measurement and dimensions of the 
label.  

See screenshot below: 

 

We currently have 9 different types of labels available for you to select from:  

� Products 
� Product Supplier 
� Shipping Header 
� Shipping Details 
� Product Warehouse 
� Product warehouse bins 
� Warehouse bins 
� PO receiving label 
� VMI Products 

 

On the “View tab” is where you specify which columns you want to see for 
filtering data for this label (Label Filters column) and what columns you want to 
see in the selection preview window when printing (see Label Printing section 
for further details).  Check off all that applies to your custom label, and click OK 
once finished. See screenshot below: 
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Once you are finished with the above screen, you will be presented with the design window for that label. See below 
for sample.   Users can modify some of the label properties at a later time by opening the label, and clicking on 
“File” and “Properties”.  You can modify any of the column selections on the “View” tab for “Label Filters” and “Label 
Details”, but can only modify the Label Name and Label Description on the “General” tab. 

 
See screenshot above: 

This becomes your blank canvas that you will use to create the label.   

 
If you position your cursor over the ‘toolbox’ button located on the top left hand side, the system will display more 
properties to assist you in the creation of you label.  These are called object types. 
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Objective Types: 

 

Textbox Objects: 

Textbox objects can contain static text, or they can be bound to a database column.  Textbox objects that are bound 
to a database column will populate with the data from the assigned column at the time of printing. 

 

Image Objects: 

Image objects are a simple container for an image file.  When you place an Image object on a label design, you will 
be presented with a “File Open” dialog box.  Browse to the image file you want to insert, and click “Open”.  Your 
image will then be inserted into the design. 

 

** PERFORMANCE NOTE ** 

Customers should be careful about the size of image files inserted into a label design, as large images can cause a 
huge performance hit when opening, saving, or printing a label.  For example, if a customer wanted to insert their 
VS logo into their label design, they should create a smaller copy of the file, since the original used by VS has very 
large dimensions.  A label containing an unmodified VS logo will take several seconds to load/print, whereas a label 
containing a reduced size logo (25%-50% of its original size) will take about a second to load/print. 

 

Barcode Objects: 

Barcode objects are similar to Textbox objects, with the exception of the Font properties.  You can modify the size of 
the font, but cannot change it with the Font dialog because we use Barcode Fonts.  You can change the barcode 
type using the “Barcode Type” combobox on the toolbar.  The currently supported types are Code 3 of  9 and 
UPC/EAN, but can be extended in the future to meet customer requirements if needed. 

 

DateStamp Objects: 

DateStamp objects can be used to display the current date (filled in at the time of printing), or they can be bound to 
a database date column.  DateStamp objects that are bound to a database date column will populate with the data 
from the assigned column at the time of printing.  You can modify the format of how the date is displayed by 
changing the format string displayed in the object. 
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Working with Objects: 

 

Text Alignment: 

You can align the text within Textbox, Barcode, and DateStamp objects by left/right/top/bottom/vertical 
center/horizontal center.  Image objects do not support text alignment because there is no text to align, and the 
image always occupies the entire area of the Image object. 

 

Object Alignment: 

You can align multiple objects by left/right/top/bottom/vertical center/horizontal center.  All objects support this 
type of alignment. 

 

Borders: 

Borders are displayed by default for all objects except Image objects.  This is to help with alignment and sizing of 
the objects.  A border can be enabled/disabled for a single or multiple objects using the toolbar. 

 

Databinding: 

You can bind all objects except Image objects to a database column by selecting a single or multiple objects, and 
selecting the database column from the “Data Binding” combobox on the toolbar.  Each object can have only 1 data 
binding, but multiple objects can bind to the same database column. 

 

Editing Objects: 

You can modify the text displayed in any object except an Image object by double-left-clicking on the object to 
enter edit mode.  Type the text that you want to display, and press “Enter” to exit edit mode and apply your 
changes.  You cannot modify the text of an object that is bound to a database column (actually, you can, but it will 
be overwritten by the database value at the time of printing).  The exception to this is the DateStamp object.  You 
can double-left-click on it to modify the format string used to display the date, regardless of whether it is bound to 
a database column or not. 

 

Multiple Selection: 

You can select multiple objects by left-click-and-dragging a selection box around the objects you want, or by 
holding in the “Shift” key and left-clicking on each object you want. 

 

Deleting an Object: 

To delete an object from your design, single-left-click on the object you want to delete, and press the “DEL” key.  
You will be prompted to confirm that you want to delete object to avoid accidental deletions. 

 

User Defined Fields: 

User defined fields are a special kind of column binding.  They show up in the Data Binding combobox as “UDF01” 
to “UDF10”.  When a label with an object that is bound to a UDF field is printed, the Label Printing Wizard will 
prompt for the value you want to appear on the printed labels.  This is only asked once, and applies to all labels 
selected to print.  You can specify the text of the prompt by double-left-clicking on the object to enter edit mode, 
enter the text you want to appear, and then pressing “Enter” to exit edit mode. 
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We will create a sample receiving label using certain object types.  Click on the Datestamp icon and then click 
anywhere on the label and it will automatically add  a field where you can later bind to a field in the software.  The 
Textbox icon can be used to add a label to indicate what the date field represents.  Continue to build your label 
based on your requirements.  When you are ready to bind (link) the fields on your label with fields from the 
software, click on the field (for example click on the date field) you will then notice that the ‘Data Binding’ becomes 
enabled.  Click on the down arrow box and select the field you want to bind the date to.  In the example above we 
are binding to the ‘receiving date’  We will also bind our field that reads ‘Product code’ with the ‘product code’ itself.   

 

Once you are finished building your label requirements, click on File > Save to save the work that has been done.  
You can then exit the program. 
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Opening an Existing Label: 

 

To open an existing label, Open the Visual Designer Software again, and then click on “File” and “Open”.  You will be 
presented with the Open Label Dialog window.  Select the Type of the label you are looking for, and what you want 
to show labels from (“All Labels”, “Global Labels Only”, or “Company Specific Labels Only”).  You will then be 
presented with the list of labels based on your selection.  You will see your label in this list that you have previously 
created, and saved.   

See screenshot below: 

 

 
 

Highlight the label you want to open and click “OK”.  The label will then be opened and the design screen will be 
displayed. 

 

 
You are now able to modify your label with whatever changes you need to make. 

Once you are done creating/modifying a label, you must save it by clicking “File” and then “Save”.  The label will 
then be saved to the database. 
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Label Printing Wizard: 

 

Integration Point: 

There is a flag that needs to be set in:  Company Setup > Control File Maintenance > Misc tab.  The flag is called 
‘Enable Label Integration’ This needs to be checked.   

See screenshot below: 

 

 
 

The label printing wizard is used to print labels that have been created using the Visual Label Designer Program.   
The wizard can be launched from the Visual Designer Program, or from within the software itself if the integration 
flag is turned on  To launch the wizard from the Visual Designer program, click on File > Print.  The system will then 
display the printing wizard.  The user needs to select the company, and the label they wish to print.   

 
There are many ways to launch the Label Printing Wizard from within the software. The type of label that you are 
printing determines where it needs to be launched from.   
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Receiving Labels: 

If you are printing Receiving Labels, this can be launched from:  Purchase order Processing > Receiving > Print 
Receiving Product Labels.   This is the manual process for printing receiving labels, this can also be done directly 
from the receiving po screen.    

 
 

If you are printing using the manual stand alone print program, you need to specify the po # that you want to print 
receiving labels for.   If you are printing directly from the PO receiving screen, the system already knows the po 
number, and therefore that information is bypassed.    In the example above we are printing from the receiving 
screen.  There is button located on the bottom right hand side called ‘Receiving Labels’.  Once you click on this, the 
system will display a small pop up with the PO # , receipt number, and supplier.  This information is automatically 
pulled from the record that you are receiving.  Click on the Label Details button.   

 

 
Click on the Label drop down box located on the top right hand side to select the type of receiving label you want 
to print.  Click Process, and a printer dialogue will be displayed, and your label will print. 
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Shipping Labels: 

 

 If you are printing shipping labels, this can be done from Sales order processing > shipping > Print shipping labels.  
This is the manual process for printing shipping labels, and will require you to select the sales order etc.  Shipping 
labels can also be printed directly form the invoice preparation screen, and also from the shipment  

Confirmation screen. 

The example below is from the invoice prep screen, there is a shipping label button located on the bottom of the 
screen.  Locate the sales order that you want to print shipping labels for, and then click the ‘shipping labels’ button, 
and then select the type of shipping label that you are wanting to print.  The system already knows what order you 
are printing the labels for, based on where you are parked on. 

 
The example below is from the shipment confirmation screen.  There is a button located on the top right hand side 
of the screen called ‘shipping label’ 
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Inventory Labels: 

 

Inventory labels can be printed from:  Inventory >Label Printing > Label Printing Wizard. 

 
The program that is launched is the same program that you are seeing in the other applications.  Click on the Label 
drop down arrow located on the top right hand side of the screen and select the type of label that you want to 
print. 

 

 
 

Once you have selected the type of product label that you want to print, click on the range options to select the 
fields that you want to use as filters.  Only columns that were selected in the labels “View” tab under “Label Filters” 
will appear in the drop down list.  In the example above, we have selected the filter for product ID, on the next field 
we select the product that we want to print labels for.  Click Process, and the printer dialogue box will be displayed 
where you can specify the number of labels required.    


